pkgbuilds/kouhai/PKGBUILD

29 lines
720 B
Bash

pkgname=kouhai
pkgver=0_alpha11
pkgrel=0
pkgdesc="Your everyday IRC student"
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
url="https://git.sr.ht/~taiite/senpai"
license=('ISC')
makedepends=('go' 'scdoc')
_commit=4d929133422d736a32999deaaf03dd7d54793abe
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mlunax/kouhai/archive/$_commit.tar.gz")
sha256sums=('fa8a2c307b4885b8994001453c00ee91e040a67a9f3d1f3b8d28364dd209aaf9')
build() {
cd $srcdir/kouhai-$_commit
sed -i "s/production/$pkgver/" window.go
make GOFLAGS="$GOFLAGS"
}
check() {
cd $srcdir/kouhai-$_commit
go test ./...
}
package() {
cd $srcdir/kouhai-$_commit
make PREFIX=/usr DESTDIR="$pkgdir" install
}